LVK Software Installation

Hi there, we just got a new STAR installed and I’m working on getting it validated and running. We have an LVK that I want to use, but I’m having an issue getting the method to run. I’ve installed the software using the cd included with our LVK, but when I run the method I get the error: “SYSTEM : Execute method - error; An error occurred while running Vector. The error description is: C:\Program Files (x86)\HAMILTON\Library\LVK\HSLLVKService.hsl(82) : Class not registered (0x23 - 0x2 - 0x39)”

Has anyone ran into this before?

Are you running from the LVK UI or directly running the method from Run Control? The LVK method can only be run from the UI.

If that’s not the case, then it sounds like there was an issue when installing so a reinstall or repair may be needed.

I was trying both, when running through the LVK UI the method would abort after initialization with no error message which led me to try running in Run Control to see if I could find an error. That’s good to know it can only be ran from the UI though.

Unfortunately I tried reinstalling but it did not fix my issue.

When running the LVK through the UI, a run trace will still be generated as if it were launched by any other method via run control. Could you please post a run trace after the run aborts when launching via the UI?

You can upload via the Hamilton shared folder.



I uploaded the trace file, but I’m realizing this isn’t an LVK issue now and is instead an issue with our autoload. I think this is likely out of the scope of this forum now and will reach out to Hamilton support.

Correct - this will likely be a simple fix for technical support.