Biomek 5 software can't create / write to files in default directories (Win11)

Hi All,
I recently started a new role where I’m working with Biomeks for the first time in 5+ years. I’m running into an odd problem installing Biomek 5 software on my laptop for offline dev / simulations etc.

Everything installs just fine (I have local admin privileges on this machine) but when I go to edit the Hardware setup it has trouble creating and accessing the recovery file (it is never actually created when you check the directory).


A similar problem happens when running a simulation where it gives the same kind of error about creating and accessing the log file.

BUT: the software absolutely CAN save hardware setup changes IF I have it open an instrument file that sits at the C:\Biomek5\ folder level (not within a specific user\Documents directory).

Biomek 5 seems it will only write logs in the C:\Users\Public\Documents\Biomek5\Logs\ directory which it cannot write to on my system. I cannot figure out a way to configure it writing logs to a different directory but could swear you used to be able to do that in my FX(p) days.

TLDR: has anybody else run into something like this trying to get the Biomek 5 software running on their own (non-beckman provided) machines? Could this be a windows 11 non-compatibility thing?

Many thanks in advance to anybody who can help! I tried to track down registry variables to see if these things could be adjusted that way and came up empty aside from pointing the software at a default instrument file location which doesn’t help the default log directory situation :frowning:


I figured out the fix here (It was an IT settings thing on my laptop): I had to log into windows with my local admin account and allow biomek.exe access to “controlled folders” (screenshot below):

Hopefully this helps someone else that runs into the same thing!


Whatever happened to the Beckman forums? Did anyone archive the old posts?

Beckman took them down; can’t even access them on InternetArchive. There is a discord group growing with a few VERY experienced biomek users that help eachother out - there’s a link floating somewhere around in these forums.

Thanks for posting the solution. I ran into a similar issue creating my own log files and had to manually create a filepath for the save location. This solution is much more future-proof.

1 Like