Hamilton Microlab Prep- using CSV Files

Does anybody have any tips on how I should format my .csv file so my Hamilton Microlab Prep robot can efficiently understand the file? I am trying to do a reagent procedure. Currently, my csv file is formatted into rows containing reagent name, target site (i.e. 1,2,3,4), target well (for well-plate at target site), and reagent volume. When I run the procedure using this file, the Prep only performs the last section of the file, skipping the bulk of the steps.

I am going to tag @Michael_Vuke because I have heard you are of good knowledge on this subject.

Hi @eliha,
the first thing I would check to make sure that the formatting of the file matches that of the template file. To check this template for your specific layout, edit the relevant step of the protocol and under the file settings click “view file requirements”. It will give a visual representation on the screen, but you can also export an example file from that screen (button in the lower left corner). Compare the formatting there.

If the file is being read for some of the steps, I’m assuming that it is formatted correctly, but I still would recommend checking this first.

One note–reagent names have to match the name of the reagent in the protocol exactly–if there is a space before, in the middle, or after the reagent name in the protocol, the space must be present in the .csv. The capitalization matters as well.

If that quick check doesn’t turn anything up, please start a ticket here: Benchtop Device Ticket

Our team will be able to dig into your protocol, file, and diagnostics to identify where the error was coming from and resolve it for you.