Hamilton vector Error 0x80131040


Our Hamilton was just recently PM’d and we are now running into this error when we try to open the system configuration in method editor (Error states: Exception has been thrown by the target of an invocation. Root Cause: 'Could not load file or assembly 'Hamilton.HxConfigEditorClassLib, Version= The located assembly’s manifest definition does not match the assembly reference. (exception from HRESULT: 0x80131040)). If I OK the message it will still bring me to the configuration page but it does not show me the MicroLab Star Venus on Vantage.

To add on to that I am not sure if these issues are connected but the reason we discovered this error is because we went to ensure the iSWAP positions were still correct after the PM and now it is running into walls of our vantage, and is not able to perform movements anymore that previously worked in the programs.

If anyone has any insight to this or has any thoughts on what we can do that would be great!
(Also I have already tried to run repair on VoV and that proved to not be useful because we are still coming up with the same error).


If Hamilton did the PM on your system I highly recommend contacting Hamilton directly as this sounds like a pretty serious issue given the gripper issue on top of the config issue.


@randob - I concur with @JDesRo. This style issue warrants additional support from your local Hamilton applications and service team.

This will likely be difficult to handle remotely, and may require eyes onsite. I will message you directly to help get you in touch with support.