HSLExcel Library has Stopped Working

Hi Everyone,

My installation of the HSL Excel library (HSLExcelLib Version 1.0.0) has recently stopped working. I’m working on Windows 10 with Microsoft 365 Apps for enterprise installed. In also running Venus Five. The library seems to have stopped working with the installation of an auto-deployed software update taking me to version 16.0.17126.20190 of Office 365.

When trying to call the “Init” function the library errors with the below dialog box:

The trace file entry is:

SYSTEM : Execute method - error; An error occurred while running Vector.  The error description is: C:\Program Files (x86)\HAMILTON\Library\HSLMicrosoftExcel.hs_(54) : Class not registered (0x23 - 0x2 - 0x39) , 

Line 54 of the referenced .hs_ file is:

HSLMicrosoftExcel_ComServer.CreateObject("HSL.MSExcel", hslFalse);

Has anyone else run into this issue? And does anyone have a potential fix?

I know that this is pretty old library (last modified by Joachim Schmid 07-Jun-2005) but it’s a library that I use all the time. As opposed to standard file handling steps, this library lets you modify the contents of a single cell in isolation. It also allows you to write formulae into cells and have the formulae execute to populate the cell with the outcome without having to open and save the worksheet in Excel external to Venus. If there is no fix for the library issue, does anyone know of a way to replace its functionality?

Many thanks for any help!

Hi @WillEb ,

Assuming Excel is still opening just fine separately from Venus, the update may have changed the path in which the library is looking for the Excel program in the registry. Can you try running the ExcelLib installer again to see if the issue is corrected? This may require an uninstall and reinstall.


My PC has the same build but was able to create the server object after installation. I did not have it installed prior, so unfortunately I was not able to reproduce the issue.

Hi @BrandonBare_Hamilton ,

Yes - Excel is still working outside of Venus.

I had forgotten to mention that I had already tried uninstalling and reinstalling the library. However, I have tried it again using your provided install file just in-case my copy had become corrupted. Unfortunately I am still getting the same outcome.

Many thanks for your help. Any further ideas?

Hi @WillEb ,

That is unfortunate. There is something else on your PC that is breaking the connection. You can try this library HSLXlLib. There is no installer for this library, so I would suggest adding the folder within the zip file to your Library folder.

This library works in a similar way as the other one, with the exception of it connects directly to the Excel Application as opposed to an intermediate. It has some extended functionality, however it does tend to operate a bit slower since it opens the file up in the background (you can make the Excel file visible if you like). I would recommend adding a 0.5 second timer after closing to give it time to fully shut down. This is only needed if your method aborts immediately after closing the file or if you need to access the file immediately after.


Hi @BrandonBare_Hamilton ,

Thank you for providing the alternative library. I’ll put it in our resources folder for a rainy day.

Since my last post I’ve done a bit more investigation. I got hold of a loaner laptop from IT with a clean install of Windows 10 and O365 (updated to the version mentioned in my original post). On to that machine I’ve installed Venus Five and the HSLExcel library and everything seems to work as you would expect (which ties in with your experience). Therefore, it does seem that something on my primary laptop is interfering with the library or something external to the library and Venus has become corrupt. Off to deskside support I go to get my laptop re-imaged… :sob:

Thank you for your help!

1 Like