HSLStatusWindow library issue

I am working on a Hamilton where we have migrated a script from a STARlet to a larger STAR. Most everything is running ok through the simulator on the STAR, however, we are running into issues with the HSLStatusWindow library on the STAR. It runs fine on the STARlet. Whether we use the HSL Status Window Init command part of it or one of the commands that writes to the Status Window, we receive an error message HxHslRunControl2 “An error occured while running Vector. The error description is C:\Program Files (x86)\HAMILTON\Library\HSLStatusWindow.hsl(32) : Invalid class string (0x23 - 0x2 - 0x39).” We are running Venus 4.5. We tried uninstalling and reinstalling the library. Then also tried reinstalling the library from the original install disc, but no luck. If I put an HSLStatusWindow.Init command after Initalize at the beginning of a test script, it immediately fails. If I disable the HSL Status Window commands, it runs. Any suggestions?

1 Like

I’ve seen that error when I import a Method containing the StatusWindowLibrary but I don’t also run the Installer on a machine that it was never installed on. You said you tried uninstalling and reinstalling the library though so I’m not sure. The error indicates it is failing to load the plugin.


9 out of 10 times that “invalid class string” error is because the library was imported with the PKG file but the installer for the library wasn’t installed.

There are a bunch of different “status window” library’s so it’s tricky to know which one is the correct installer. Worst case you just remove those steps and use the protocol without a status window.

Also, unrelated but make sure you convert the deck type as well. It’ll be fine in sim but will error out when trying to run it in real time.


Hi Mike,

I agree with Cole and Kyle. Something is likely going on with the installer and your computer/permissions that prevent it from registering.

As a side note, for our standardized solutions at Hamilton, we typically use the ASW status dialog library that gets installed with the ASW GUI installer. ASW stands for Application SoftWare so any library with that prefix is authored by our internal software team.


1 Like

Hi all, thanks for your input, really appreciate it. I got another copy of the original files and reinstalled and that resolved the issue.



This exchange is proof we’re building something new here people. Keep it coming keep it coming! :raised_hands:

1 Like