Issues with newly installed Venus

So I made a simple method because I noticed I was having some simplistic issues in my laptops Venus compared to the one in lab. Its just a file open, 1 column read as a string, loop over the file read and print the string.
I get the error “Item cannot be found in the collection corresponding to the requested name or ordinal”

So I went to the lab and made the same method and it works, printing the names as it loops. So I took the one that worked on the lab computer and imported it to my laptop with the same csv, and again I get the same error.
I re-installed and still get the same error, has anyone seen this before?

That error usually means you have a mismatch between the Headers of the file and the expected Headers in the File:Open. I would confirm that you are working with the exact same file and also that your File:Open is defined the exact way for both methods. Look for typos such as "Header " with a trailing space or that the file has header option is checked/unchecked.

1 Like

Thanks for the quick reply!
Yep I can confirm both methods are the same, and are attempting to import the same csv. The methods and file were imported from the labs computer.

I also created a new method that does similar but with different parameters, it fails on the laptop but when I import it and the csv to the lab computer it runs fine

What are the key differences between the two systems? Same OS? Same version of Venus/Jet?

On your laptop, if you drag in a file open step and go to the column specification helper (below), can you see all your columns etc?

Can you provide the .pkg and .csv?

1 Like

When using *.csv file format, a schema.ini file is automatically created. This file is used to “record” the data type in each column of the file and the number of columns. This is by design- a text file driver is used to read the *.csv, the first lines of data are read and the data type is determined. Different drivers are used to access different types of files - some drivers determine the data type internally.

It’s possible that the schema.ini files that were created on each setup are different. This can occur if you are making changes to how the file handling command in regard to the columns and data types. Try copying over the schema.ini file from the system it’s working on (or deleting the existing schema.ini file on the problematic system).

1 Like

Ok thanks everyone! After some troubleshooting I found that the error was only happening when I tried to parse the first column. When swapping columns around the first column always broke the parse. So after checking the column specification helper I see this:

It’s adding some symbols to col1’s name which don’t exist when opening the csv in notepad/excel


Might that be the BOM (byte order mark) character?

1 Like

Notepad++ can indicate whether or not a BOM is present. Microsoft Excel has export options with and without a BOM.

I checked and that was the problem, thanks everyone!

1 Like