Scheduler ans SMART Step

Hello All,

In one of my method I use some SMART Steps, thus there are some “‘PTL::Pipette3 (or 4)’ undeclared identifier” in the “Analyser Output”, it was an issue.

I currently want to use the Scheduler with this method, but when I use the Select Method step in the .wlf, Venus says “The selected method contains synthax errors”.
I tried to remove all smart step in the method, and after that, it is possible to select it in the .wfl.

Do you have any idea to remove this error ? or is it impossible to use smart steps in a .wfl ?

Thank you !

@Thib - There are no restrictions preventing use of Smart Steps in a scheduled workflow or dependent method. It sounds like the dependent method you were attempting to call for scheduling already contained syntax errors. VENUS will not allow use of the ‘SelectMethod’ scheduler command if the HSL file you are binding contains any underlying syntax errors, related to any dependency. Your case just happened to have a syntax error related to a missing reference for the underlying Smart Steps code.

Similar to HSL libraries, Smart Steps are constructed via various HSL files that contain the declarations and calls for the functions made available in the Method Editor toolkit. For Smart Steps, the high-level supporting HSL file that installs with VENUS is:

C:\Program Files (x86)\HAMILTON\Library\HSLPTLLib.hsl

It looks like your method or one of it’s dependent library files is making a broken reference to a copied location of this file that does not exist on your PC. This can happen when copies of default or custom library files are generated in additional file paths and folders on other PCs, and get passed around via import/export, where methods eventually begin to reference default libraries from non-default file paths.

Somewhere, your original method was referencing functions from the HSLPTLLib.hsl from an invalid file location, that does not exist on your PC, outside of the default file path in the Library root.


Hi @Thib,

I run into that error everytime I am using a smartstep these days. As @NickHealy_Hamilton
mentioned you are referencing the HSLPTLLib library in the wrong folder, usually either in same folder as the method or one folder above. What I found out is that by deleting all extra HSLPTLLIB.hsl library files in those non-library folder, the error goes away. Venus somehow restablishes the connection to the default HSLPTLLib.hsl file in the library folder. Note that the error will likely come back if you import the method again.

Hope that help.