[Solved] Inheco MTC Library Problem

Hi everyone,

I hope someone could help me out here since I am lost. I have 4 Inheco CPAC that is connected to my instrument but I’m experiencing difficulties using the Inheco MTC library provided from by driver. Every time I tried to run the protocol using the library to control the CPAC via Venus, this error pops up.

Screen Shot 2023-10-25 at 4.40.50 PM

I tried reaching out to my local Hamilton team but I’m also experiencing difficulties reaching out to them.

Any help is appreciated as always,


It might be improper installation of the library drivers. I believe this is a .exe installation file that is required because you are using Inheco’s controller.


Hi Nat,

It looks like the driver installer may need to be run (or repaired). If you could upload your test method and a trace file to this folder that could potentially help us diagnose further. Password is Hamilton23.

I can also help get you in touch with your local team who may be more familiar with your setup. I messaged you separately.



Hi @EricSindelar_Hamilton

I am unsure on what you mean by a trace file nor have a clear idea of what that is. Could you further elaborate please?

Thank you

Every time you execute a method using run control, it creates a *.trc file, which is the trace or Log File. These are kept in the Hamilton\LogFiles directory. The name of the file will be the method’s name, followed by a unique run id. You can sort the folder by Date Modified to help find the trace file that had the error.

UPDATE: The issue has been resolved thanks to @EricSindelar_Hamilton :partying_face: