Venus 6 Error Reporting


I wanted to create this thread so we can collectively report errors with Venus 6.

I’ll start:

  • ISwap place command: Advanced dialog is now missing so I cannot enable / disable collision control

  • Track gripper: Taught locations no longer request the correct access region. This can cause collisions in the pipetting deck because the pipetting gantry will not move out of the way.

  • Tip roll off on eject: Setting does not seem to do anything. I cannot get the tip roll off to work at this time.


The plot thickens. I CANNOT use the iSwap currently. See error below:

@DanHartman_Hamilton @EricSindelar_Hamilton @BrandonBare_Hamilton

2024-03-05 16:47:21> Microlab® STAR : iSWAP Get Plate (Single Step) - start;
2024-03-05 16:47:21> Microlab® STAR : Main - error; An error occurred while running Vector.  The error description is: Negative value received but positive value expected.   (-1  found in key Instrument::collisionControl) (0x28 - 0x2 - 0x808) 
2024-03-05 16:47:21> Microlab® STAR : iSWAP Get Plate (Single Step) - complete with error; An error occurred while running Vector.  The error description is: Negative value received but positive value expected.   (-1  found in key Instrument::collisionControl) (0x28 - 0x2 - 0x808)   > :

See image below where “Advanced” is missing…


The Advanced section would only have the “enable / disable collision control” function, but this option has no effect in VANTAGE 6.0. It´s intended only for the pipetting arms in dual arm systems, not for the gripper itself. In version 6.2, this Advanced option will be included to allow disabling of the iPG collision control instead of the dual arms.

As for the errors you’re getting, something else must be going on with your setup as I see STAR in the trace, but I presume this is for a VANTAGE. Please provide more context - VENUS 6 version, what instrument you’re working on, what installer was run (there are separate VENUS 6 installers for VANTAGE and STAR), and if this was a clean install or was installed on top of an existing VENUS setup.

Troubleshooting install issues over a forum is not ideal though so it may be prudent to have local apps assist.


Hi @BirdBare,
I agree with Eric, I´d double check that you haven´t installed anything on top of the VANTAGE install.

Missing ‘advanced’ Place Plate dialog
I assume that you are working with a method written in a previous VENUS version. In the Method Editor try to open the existing Plate Place step, click OK to close the dialog, then save your method. That should re-write the code for that step.

Track gripper collision control with taught paths
This has been fixed in the upcoming 6.2 release in May/June. In the meantime, use the Move to Position command to manually move the pip arm away if needed.

Tip roll off on eject
Can you give us more details about your system configuration and what waste you are trying to do the tip roll off on? (a screenshot of the decklayout would be perfect)


Thank you!

This was a “clean” install on a new PC. An application specialist came onsite to perform the installation. I say clean because there were quite a few issues with the DB creation that required a full uninstall and reinstall. I was not aware of 2 installers for Venus 6 but I presume I have the Vantage version.

Vantage instrument.

@AlvaroCuevas_Hamilton is correct. I was working with a previous Venus method and as such that caused the error. I updated the steps as he suggested and the error went away.

Great to know the track gripper has been fixed in an upcoming release!

As far as tip roll off: I have a vantage with a universal waste in module position 2. I have the system configuration to roll off right but no roll off is occurring.

Try re-snapping the universal waste in your deck layout:

  1. Open the deck layout
  2. Click to select the waste
  3. Drag it until you see the 4 arrows indicating a correct snap into position

The universal waste snap sites have been updated in VENUS 6 and you probably need a minor adjustment. If it´s not matching the X position, due to a bug it will disable the tip roll off (this has also been fixed for the next release)


Amazing! I will try this

Edit: Fixed it!



A few annoying bugs I believe:

  • The entry exit initialization requires that the pipetting gantry is not above it. I had to add a MoveToPosition step to move to waste so it was out of the way. Is it possible to move the gantry to waste after ML_STAR initialization (or all initialization) so it is not directly above the EE? It would be nice to also move it to waste upon end method if that is possible as well.

  • The labware position training is VERY slow after clicking OK (the cleanup portion). Can the commands be executed quicker?

For the EE initialization, yes you can add one MoveToPosition command after the initialization. This has been addressed in an upcoming version. It’s good practice to include the MoveToPosition command at the end of the method and in the OnAbort tab.

For the labware position training, from our testing, it seems to be ~5 seconds. If it is excessive, please provide a comm trace so we can investigate.

Hello Brady,

This is great. @EricSindelar_Hamilton should we post here for venus 6 on star also or make a separate one for star?

You can post them here. It would be helpful if VENUS version number, platform, and OS were provided at a minimum. Trace and com trace files also would help.

Please know that many items have been addressed in the forthcoming 6.2 (estimated for June release). As soon as it is available, I will update the forum and provide the release notes.

Hi Alvaro,
I’m facing the same issue, however resnapping does not fix it. The tip waste position is about 10 mm off to the right.
I have had my VENUS updated to today. Any recommendations?

It definitely worked for me. Are you snapping the waste bar?

Green part.


  1. Check your instrument setup in the System Configuration Editor. In what slot is your Universal Waste defined? Is this a 2.0 or 1.3m system?
  2. Open your layout in the method editor and resnap the waste. Then right click on the waste bar > adjust location and post a screenshot of the X coordinate.

Hi Alvaro,
I’ll try this on monday. Waste slot is on position 3 in a 2m system. However, I only snapped the universal waste, did not know that I have to snap the waste bar in addition…

Got it to work, I was just to stupid to move the waste tray to the correct spot -.-. Other than that I like the new design of VENUS 6 especially the shortcuts to anything. Will make my job explaining stuff to my lab much much easier :slight_smile:

1 Like

Okay, I got almost everything fixed but one error, and I’m sure I cannot be the only one: In the new run control my deck layouts are bricked and I did not find a way to fix it

Legacy run control:

Same deck layout in the new run control:

If I recreate the deck layout with VENUS 6 they look fine, I just don’t want to recreate N deck layouts with k sequences. Please tell me there is an easy fix for this :pray:

€dit: Maybe as an update: The new run control seems to not show anything that does not have a .x connection, which is not optimal, since there is not a .x definition for everything. Concerning the MPE, at least the positioning seems to be fine after removing it and putting it back on the deck.

Hi Dominik,
I´ve sent you a DM with instructions to send me the files for investigation. Thanks!