Venus Downloads for Dev Work

Interested in hearing if anyone has been able to secure a copy of Venus for development work without having an actual Hamilton. Would love to try and work on some independent features/libraries without the need to burden an employer with a request for resources


I have it on a laptop at home. You can install it on any windows laptop. Never tried any mc - pc bootcamp stuff so can’t attest.

@EricSindelar_Hamilton can you upload the Venus installer?

I got the .iso files when I went on their workshop, and have it on VMs. I’m sure Eric can upload it.

Use this link for the VENUS four installer

Admin edit: updated link


Much appreciated Eric, thank you! Hoping to have some cool stuff to contribute to the user libraries in the near future :slight_smile:


I do most of my work on an M1 Mac using VM’s…

Just as an FYI.


@luisvillaautomata I tried installing venus on an M1 macbook using Parallels VM but couldn’t because of the SQL Drivers. How did you get past it? What VM did you use?

VMware (Workstation, but Player is fine too) with a Windows 10 guest works great for my team.



Did you ever figure this out? Running into similar issues

1 Like

What issue?

I’m unable to get the Hamilton SQL Server up and running on a Parallels VM (M2 Mac) running Windows 11 ARM (only OS available to me at this time). I have tried tweaking a few things like login credentials but server start up just times out. @luisvillaautomata, what’s you’re VM set up if you dont mind me asking?

How are you testing this on Venus? Let me look at my build

Only solution was to downgrade to a 2019 macbook pro :frowning:

Hi Luke, did you ever find a solution to this? I’m running into the same issue trying to establish a connection

Hey Chris, I was able to get a new server set up through the system configuration editor. I believe it’s in the database connection settings, there’s an option to prepare a new server. The default Hamilton server failed to start so I created a new SQL express server and used Venus to prepare that. Appears to be working without issue. Hope that helps!


Hi Luke, similarly to what I think you were seeing, I’m trying to install Venus on my Parallels system. What I’m seeing is a failure of the SQL Server Windows Service to remain running. I have tried to prepare a server but when testing this connection I’m still seeing an error:
Cannot open database connection…error 26 - Error locating server/instance specified.
Any insight would be amazing. Thanks!

Been meaning to reply to @chips-a-hoai about this as well. I haven’t had a chance to set up a fresh parallels instance yet to refresh my memory, but here’s the gist:

I followed this guide for installing a new SQL server instance which I left under the default name of SQLEXPRESS.

During the install, you may need to do some repair/install steps to download the correct packages for Windows 11 ARM. I think the original Venus install skips these checks which causes the initial issue. Once the new SQL server is set up, go to your system configuration editor and update the vector database connection setting with the credentials for the SQL server you just set up.

I believe that was all I had to to do, let me know if you run into issues and I can try to help troubleshoot!

I’m interested to hear that several people are having issues with VMs. Are you on apple or intel chips?
I use Parallels, with a Windows 11 machine and have had no issues at all… I’m on a 2014 iMac though…

this is specific to the M1 macbooks. @LukeWitt how were you able to install the SQL server? When I tried installed MS SQL Server 2014, it wasn’t supported by the M1 chip.

Does the 2019 instance of the SQL server work with Hamilton software?

1 Like